快捷搜索:

也就是先安装rvm(Ruby版本管理器)

今天安装cocoapods时候出现了下面的提示Error installing pods:active support requires Ruby version >= 2.2.0这个需求的意思就是Ruby版本低, 需要更新至2.2.0以上版本.所以我就想办法更新Ruby.网上最方面的方法是用rvm安装, 也就是先安装rvm(Ruby版本管理器), 再更新Ruby.

先查看你是否安装过rvm, 执行命令

rvm -v

如果显示是图1所示, 那就是没有, 需要安装.

图片 11.png

下面来进行安装1> 首先打开终端输入如下命令:

curl -L get.rvm.io | bash -s stable

图片 22.png图片 33.png

2> 再输入

source ~/.rvm/scripts/rvm

3 > 查看是否安装成功, 输入下行

rvm -v

如果有版本信息显示了, 就说明安装成功, 就是图4的样子

图片 44.png

4> 列表显示都可以安装ruby的哪些版本

rvm list known

图片 55.png

5> 更新ruby至版本2.3.0

rvm install 2.3.0

如果更新过程中没有error, 更新结束后输入命令ruby -v看看是不是2.3.0版本, 如果是的话, 恭喜, 如果需要安装cocoapods, 你可以继续正常安装了.如果安装过程中有问题, 往下看, 是不是与我遇到的问题一样.

安装过程中有下面的错误, showing last 15 lines of /Users/LL.F/.rvm/log/1475202192_ruby-2.3.0/make.logThere has been an error while running make. Halting the installation这个错误信息是因为电脑中有多个版本的Xcode

图片 66.png

这样解决⬇️ 终端输入

xcode-select --install

此时会弹出一个软件安装信息 点击安装 安装结束后继续在终端输入

rvm install 2.3

就会有图8安装完成的字样, 这个问题就解决了,然后再去安装cocoapods

图片 77.png图片 88.png

本来我的ruby已经是2.3.0版本了, 但是我想练习一下从安装rvm开始, 于是我就进行了下列一系列的操作 卸载rvm

rvm implode 卸载完成后开始安装, 就是重复1> ~ 3> 步骤, 现在rvm安装好了

图片 99.png

更新ruby到2.3.0

rvm install 2.3.0

更新完他提示我已经是2.3.0版本

图片 1010.png

所以我就查了一下当前到底是什么版本

图片 1111.png我还抱着侥幸的心理, 用ruby use 2.3.0 --default设成默认的, 还是不可以图片 1212.png

我就奇怪了, 竟然不可以, 那好吧,我就按他的提示重新安装一下2.3.0那么问题来了:给了我下面这些的错误信息

图片 1313.png图片 1414.png

后来找到了解决办法, 如图15的解决办法终端输入下面命令等一会就安装成功了, 我的ruby终于解决了

__rvm_rm_rf /Users/LL.F/.rvm/rubies/ruby-2.3.0

图片 1515.png图片 1616.png

本文由澳门新葡萄京8455官网发布于澳门新葡萄京8455官网,转载请注明出处:也就是先安装rvm(Ruby版本管理器)

您可能还会对下面的文章感兴趣: